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C# Lab 1: Creating a Web Browser

To open MS Visual Studio:

Start->All Programs->Microsoft Visual Studio 2017->MS Visual Studio 2017

(If necessary…) Select Visual C# Development Settings.

To start a new project open:


New Project

In the next screen you will specify to use C# for a Windows Application, and name the program:


Select:  Windows Form App (.NET Framework)


Name=WebBrowser


Press OK

In the next screen a form (“Form1”) will appear.  You can make your screen somewhat bigger by dragging its edge.

Look for (and if necessary open) the ‘Toolbox’ containing Common Controls: ‘Button’, ‘Checkbox’, …  This should be on the far left side of your screen.

Drag and drop a ‘Button’ onto the form.  Look for the ‘Properties’ window on the bottom right side of your screen.  Within Properties, set the following values:


Appearance-> Text=Go


Design-> (Name)=goButton

You may resize the button by dragging its edge.

You have just given a ‘Text’ label to the button and a name you will use in your program: goButton.  You may also change the color of the button if you like, by finding and changing the appropriate property.

From Toolbox, drag and drop a ‘Label’ onto the form.  Move the label to the top of the form.  Within the Properties window, set the following values: 


Appearance-> Text=Enter URL and Press Go


Design-> (Name)=directions

Drag and drop a ‘TextBox’ onto the form.  Move the textbox and button so that they are on the same line (next to each other) with the button on the right.  Resize the textbox so that it is large enough to enter a fairly long URL.  Within the Properties window, set the following values:


Appearance-> Text=” “


Design-> (Name)=url

Drag and drop a ‘WebBrowser’ onto the form.  Resize it and place below URL and GoButton.  Within the Properties window, set the value:


Design-> (Name)=browser

If you right-click on the form itself, you can modify its properties, including changing the background color.

Now you are ready to program.  Double click the Go button.  The code is now displayed with an empty function ‘GoButton_Click()’.  This function will be called whenever the Go button is clicked.  What we want to do is set the Browser text to the URL listed in the URL textbox.  Code as follows:


try {



this.browser.Navigate(this.url.Text);


} catch (Exception ex) { 

Console.WriteLine("Exception source: {0}", ex.Source); 

}

Notice that as you type, you are prompted for possible extensions.  This ‘IntelliSense’ feature helps you know what attributes and member functions exist for whatever object you are working with (as long as the object is predefined in your file).  It serves as help and works for all the system libraries too!

Select the form design mode again by selecting the folder: “Form1.cs [Design]”.  Double click on the form background.  You will return to the form constructor at the newly-created function “Form1_Load”.  You may select what the browser should display as the application is started up.  You may code there (please type this in yourself, do not cut and paste):


this.url.Text = “www.cs.uwp.edu/Classes/Cs370”;  (or other site as you like)


this.browser.Navigate(this.url.Text);


webBrowser1.ScriptErrorsSuppressed=True;    // play with this line to get to work

To compile, execute:


Build->Solution

You should see at the bottom of the screen in ‘Output’:  Build succeeded

To run, execute:


Debug->Start Debugging

(There may be an error but continue anyway.)

If your Browser isn’t big enough, try resizing it.  Not good?  Stop the debugging by closing the form.

And then try the following.  On Form1.cs [Design], anchor each form item on the screen at its current location.  Then when it resizes, it will expand or reduce in size with the window.  For each control on your form, set the Layout-> Anchor property as follows:


TextBox:
Top, Left, Right


Button:
Top, Right


WebBrowser: 
Top, Bottom, Left, Right.

Show the instructor when you are done.

For Hacker Status:  Add a ‘Back’ button to the form. 
C# Lab 2:  Creating a Web Form
How to create the web form application.

Open Microsoft Visual Studio 2017
If it asks you to Sign in, check: Not now, maybe later.
If necessary: Select C# as language

Select: File -> New Web Site
Select: ASP.NET Empty Web Site

Select a good filename with your name on it.
You will see the Solution Explorer on the top right side,

The Properties on the bottom right side


The Toolbox on the far left side.

Create a form by right-clicking on the Solution Explorer (empty part).

Add -> Web Form


Specify name for Item:  Item Name: <NameSchedule>

The web page appears as an HTML form.  Select the Design (or Split) option below the web page.

In Design, we set up what the web page will look like:
     Enter “Welcome to the Calendar Program” at the form’s prompt.  

     Enter a few carriage returns, and then: “Enter schedule about this date”

     Select Toolbox ->  TextBox, and drag and drop the TextBox below the question.

     Select Toolbox ->  Button and drag and drop the Button next to the TextBox.

     Select View -> Properties Window

     In the Properties area, set the Button’s “Appearance->Text” (name) to “Go”.

To change the Button’s name, modify “Misc->(ID)”.

     Select Toolbox ->  Label and drag and drop the Label below the Button.
          In the Label’s Properties Box:

              Resize the Label to a Height of 100 and Width of 600 Pixels.

              Rename the Label’s Text to “Schedule”.

     Select Toolbox -> Calendar and drag and drop a Calendar below the Label area.

     You may change colors on each item in the Properties area, if you like.  

     Using the Format Drop Down Menu, you may change the form’s Background Color
Programming the Code-Behind:

     Double click the Go Button.  A form class with methods will be created.

     In the Button1_Click() method:

     Add the following code, where the <BR> inserts an HTML break-line:
           Label1.Text += "<BR />" + TextBox1.Text;
     Return to the Default.aspx tab (showing Design).  Recognize that when you click on 

     any item you can see the name of any attribute:  TextBox1, Button1, Calendar1.

     Double click the Calendar. 

     Add the following code:

      Label1.Text = Calendar1.SelectedDate.ToLongDateString();

To execute the form, select:

Build->Build Solution

Debug->Start without Debugging (or Start with Debugging)
    Click on dates in the calendar and look at what displays.

    Enter text into the TextBox, then press ‘Go’.

Enhance your program as follows:

    When the Go Button is pressed, the TextBox should clear.

For Hacker Status: When the form is entered, read a file into Label1. Directions on how to use files is on my C# notes on my www.cs.uwp.edu/Classes/Cs370 website.
Programming with C#

File Manipulation

The file manipulation described in this section is to read and write strings.  To learn about other file manipulation classes, please refer to a text.
First, all file manipulation is in the System.IO library.  You may specify this library at the top of your code or you may specify the full library every time you want to use an item within it (e.g., System.IO.FileStream):

using System.IO;


…


String fPath = @”C:\Users\Student\temp\<filename>”;


FileStream fs = new FileStream(fPath, FileMode.Create);


StreamWriter writer = new StreamWriter(fs);


writer.WriteLine(“Text”);


writer.Close();
StreamWriter functions include: Close(), Flush(), Write(), WriteLine().  Open options include FileMode.Append, FileMode.OpenOrCreate, and others.  Another example:

string fPath = @”C:\Users\Student\temp\<filename>”;


FileInfo fout = new FileInfo(fPath);


using (TextWriter tx = fout.AppendText()) {



tx.WriteLine(“a string”);



tx.Close();


}

Reading from Files

A string reader class exists also:

using System.IO;

      const string sPath = @"C:\Users\Student\Documents\My Web Sites\filename.txt";


FileInfo fin = new FileInfo(sPath);


using (StreamReader stRead = fin.OpenText()) {



while (!stRead.EndOfStream) {




string s = stRead.ReadLine());



}


stRead.Close();


}



…

Other functions include Peek(), Read(), ReadLine(), ReadBlock(), ReadToEnd().

Include the full directory name.  To find the directory to put your file, use File->Save as.
Strings

To create an array of strings:


string[] animal = new string[6];


array[0] = “dog”;


array[1] = “cat”;

Or you can use String[] animal = new String[6];

ListBoxes

The examples below add to an array element called a listbox – which you may or may not use. Here is some sample useful code:

        string temp = this.textBoxNews.Text;

        listbox.Items.Clear();
// clears the listbox
        listbox.Items.Add(temp);

        String s = listbox.Items[2].ToString();

        if (listbox.Items.Count.Equals(10))

            listbox.Items.RemoveAt(1);

Random Number Generation

The following sample code creates and obtains a random integer.

 
Random r = new Random();


int count = r.Next() % maxValue;
To print count, use count.ToString();
Sleeping with Threads

To get a thread to sleep, using the following include at the top of the file, and the following call in your code.  Pass the milliseconds to sleep in the Sleep() call.  (1 sec = 1000 ms).


using System.Threading;


Thread.Sleep(1000);

// Sleep one second

Writing to the Console

This is available for debug in forms, but not web pages.  Use similar to java:


Console.WriteLine(“Whatever you want” + variable + “more stuff”);

Or if a newline is not desired:


Console.Write(“Comment, comment”);

Working with Microsoft Visual Studio on Lab Computers

Modifying an Existing Program

Double click the .sln (or Solution) file to start the program, assuming Microsoft Visual Studio is available.

Any C# code uses the extension .cs.  For example, form1.cs has the C# code for behind the form, including any functions that are to be called as buttons are pressed or text is entered on the forms.  Within form1.cs, there is one function automatically created by .NET for each button to be pressed or box to have text entered.

The executable is within the repos directory.  It will only run if the proper versions of .NET libraries are available.  If you port an executable to your home laptop where you don’t have these libraries available, the .NET code will not execute.  However, the .NET libraries can be downloaded from a Microsoft web page for free.

Since the syntax for C# is similar but not the same as Java, it is often best to use the Intellisense feature.  As you type, alternative choices (e.g., functions, attributed) are made available to you, as long as the objects you are using are already defined.

Saving Off Your Code For Later Debugging

If you leave your program on the Windows machine, you may lose it.  To save off your work, you must copy two directories to your storage, and reload these same directories to resume working:

\Users\Student\source\Web Sites\<your project name>

\Users\Student\source\repos\<your project name>

When you want to reload, be sure to reinstall both directories, then click on the <name>.sln (or solution) in the repos directory.

Testing Your Code

After you compile and run your code, you may create multiple copies of the same form by opening new browsers and copying the URL from the first browser.  The URL may look something like this:  http://localhost:51765/Default.aspx.

Developing C# on Linux…???  (Not tested in 2017)

This may not work this year… If you choose to run your C# application with Mono, you can 1) compile your application on Linux using Mono (using gmcs) or 2) compile your application with Visual Studio on a Windows machine and copy the generated application exe file to Linux. To run your program with Mono, execute:


$ ./your_application.exe

- or -


$ mono your_application.exe

For more information on Mono:


$ man mono 

For more information on compiling C# against the .NET 2.0 specification:


$ man gmcs

